Book a Free Product Demonstration
Compare picture quality, touchscreen performance, software and connectivity with guidance from a commercial display specialist.
High-Performance L2+ PoE+ Solution with Static Routing
The IGS-4215-16P4X is PLANET's Industrial-grade, DIN-rail L2+ Managed Gigabit PoE+ Switch, upgraded with L2+ static routing to enhance inter-VLAN communication and network efficiency. It offers 16 10/100/1000BASE-T ports with 802.3at PoE+ (up to 36W per port) and 4 10GBASE-X SFP+ fiber slots for high-speed uplinks.
With a total PoE power budget of 360 watts (achievable only with dual power inputs), it supports diverse PoE applications, including IP cameras and wireless access points. Operating in extreme temperatures from -40 to 75°C, the IGS-4215-16P4X features advanced PoE management, IPv6/IPv4 dual stack support, and a rugged IP30 aluminum enclosure. Its USB Type-C console port ensures simple management, making it a reliable choice for demanding industrial environments.
Cybersecurity Network Solution to Minimize Security Risks
The IGS-4215-16P4X supports SSHv2 and TLSv1.3 protocols to provide strong protection against advanced threats. It includes a range of cybersecurity features such as DHCP Snooping, IP Source Guard, Dynamic ARP Inspection Protection, RADIUS and TACACS+ user accounts management, SNMPv3 authentication, and so on to complement it as an all-security solution.

Modbus TCP Provides Flexible Network Connectivity for Factory Automation
The IGS-4215-16P4X supports the Modbus TCP protocol, allowing for easy integration with SCADA systems, HMI systems, and other data acquisition systems in factory floors. This enables administrators to remotely monitor the industrial Ethernet switch's operating information, port information, communication status, and DI/DO status, thereby enhancing monitoring and maintenance of the entire factory.
Redundant Ring, Fast Recovery for Critical Network Applications
The IGS-4215-16P4X supports redundant ring technology and features strong, rapid self-recovery capability to prevent interruptions and external intrusions. It incorporates advanced ITU-T G.8032 ERPS (Ethernet Ring Protection Switching) technology and Spanning Tree Protocol (802.1s MSTP) into customer’s network to enhance system reliability and uptime in various environments.

Reliable Power and High-speed Data with IEEE 802.3at PoE+ Support
The IGS-4215-16P4X is designed to meet the needs of networks with smaller to medium PoE power demands, complying with the IEEE 802.3at PoE+ standard. It delivers a total power capacity of 360 watts across its 16 PoE+ ports, with each port supporting up to 36 watts of power. This makes it ideal for powering a range of medium-power PoE-compliant devices (PDs) over standard Cat5e/6 Ethernet cabling.
The IGS-4215-16P4X is better suited for applications with multiple devices that require moderate power. It’s an excellent choice for:
PoE IP cameras
Wireless access points (APs)
IP phones and VoIP systems
Digital signage displays
Industrial IoT devices
ONVIF Support Allows Effective and Centralized Control Over IP-based Security Products
The IGS-4215-16P4X switch offers ONVIF support as part of its versatile feature set for seamless integration with IP surveillance cameras. Through the switch's web GUI, users can easily search for and display all ONVIF-compliant devices on their LAN.
Users can also upload floor plans to the switch and place IP surveillance cameras on the plan for more intuitive planning and faster inspection in the future. Additionally, the web GUI provides real-time surveillance information, online/offline status, and the ability to remotely reboot cameras.

Intelligent Powered Device Alive Check
The IGS-4215-16P4X can be configured to monitor connected PD (powered device) status in real time via ping action. Once the PD stops working and responding, the IGS-4215-16P4X will resume the PoE port power and bring the PD back to work. It will greatly enhance the network reliability through the PoE port resetting the PD’s power source and reducing the administrator’s management burden.

Scheduled Power Recycling
The IGS-4215-16P4X allows each of the connected PoE IP cameras or PoE wireless access points to reboot at a specified time each week. Therefore, it will reduce the chance of IP camera or AP crash resulting from buffer overflow.

PoE Schedule for Energy Savings
Under the global trend of energy savings and contributing to environmental protection, the IGS-4215-16P4X can effectively control the power supply besides its capability of giving high watts power. The “PoE schedule” function helps you enable or disable PoE power feeding for each PoE port during specified time intervals, which is a powerful function to help SMBs or enterprises save power and budget. It also increases security by powering off PDs that should not be in use during non-business hours.

802.3at PoE+ Power and Ethernet Data Transmission Distance Extension
In the "Extend" operation mode, the IGS-4215-16P4X operates on a per-port basis with a 10Mbps duplex configuration. It can deliver 15-watt PoE power output over a distance of up to 250 meters, exceeding the standard 100-meter Ethernet UTP cable limit. This extended range allows PoE power to be supplied over longer distances without the need for additional cabling or electrical outlets, significantly reducing installation costs while maintaining network reliability.

Effective Alarm Alert for Better Protection
The IGS-4215-16P4X incorporates a Fault Alarm feature that promptly notifies users of any issues with the switches. This valuable feature eliminates the need for users to spend time locating the problem, resulting in significant time and human resource savings.

Digital Input and Digital Output for External Alarm
The IGS-4215-16P4X supports Digital Input and Digital Output through a terminal block located on its upper panel. This external alarm enables users to use Digital Input to detect and log external device status (such as door intrusion detector), and send event alarm to the administrators. The Digital Output could be used to alarm the administrators if the IGS-4215-16P4X port shows “link down”, “link up” or “power failure”.

Environmentally Hardened Design
With the IP30 aluminum industrial case, the IGS-4215-16P4X provides a high level of immunity against electromagnetic interference and heavy electrical surges which are usually found on plant floors or in curb-side traffic control cabinets without air conditioner. Being able to operate under the temperature range from -40 to 75 °C, the IGS-4215-16P4X can be placed in almost any difficult environment.
Robust Protection
The IGS-4215-16P4X provides contact discharge of ±6KV DC and air discharge of ±8KV DC for Ethernet ESD protection. It also supports ±4KV surge immunity to improve product stability and protects users’ networks from devastating ESD attacks, making sure the flow of operation does not fluctuate.
Layer 3 IPv4 and IPv6 VLAN Routing for Secure and Flexible Management
The IGS-4215-16P4X switch delivers high-performance transmission and advanced Layer 2 and Layer 4 functionalities, along with Layer 3 IPv4 and IPv6 static routing. This capability enables efficient routing between different VLANs and IP addresses, offering a secure, flexible, and straightforward networking solution for diverse applications.

Robust Layer 2 Features
The IGS-4215-16P4X can be programmed for advanced switch management functions such as dynamic port link aggregation, 802.1Q VLAN, Q-in-Q VLAN, Multiple Spanning Tree Protocol (MSTP), loop and BPDU guard, IGMP snooping, and MLD snooping. With dynamic port link aggregation, the switch enables the creation of a high-speed trunk. For instance, it can combine four 10G ports, creating a resilient 40Gbps connection with fail-over support. Additionally, the inclusion of Link Layer Discovery Protocol (LLDP) enhances Layer 2 functionality by providing essential information about neighboring devices within the local broadcast domain.

Efficient Traffic Control
The IGS-4215-16P4X is loaded with robust QoS features and powerful traffic management to enhance services to business-class data, voice, and video solutions. The functionality includes broadcast/multicast/unicast storm control, per port bandwidth control, 802.1p/CoS/IP DSCP QoS priority and remarking. It guarantees the best performance in VoIP and video stream transmission, and empowers the enterprises to take full advantage of the limited network resources.
Enhancing Network Security
PLANET IGS-4215-16P4X offers comprehensive IPv4/IPv6 Layer 2 to Layer 4 Access Control List (ACL) for enforcing security to the edge. It can be used to restrict network access by denying packets based on source and destination IP address, TCP/UDP ports or defined typical network applications. With the protected port function, communication between edge ports can be prevented to guarantee user privacy. Furthermore, port security function allows to limit the number of network devices on a given port. The network administrators can now construct highly-secure corporate networks with considerably less time and effort than before.
Ensuring Network Integrity
The IGS-4215-16P4X also provides DHCP Snooping, IP Source Guard and Dynamic ARP Inspection functions to prevent IP snooping from attack and discard ARP packets with invalid MAC address. Its accuracy, consistency, and reliability of data can be transmitted across a network. Moreover, it ensures that information remains unaltered during transmission and that the network itself is secure from unauthorized access or attacks.
User-friendly and Secure Management
For efficient management, the IGS-4215-16P4X is equipped with Command line, Web and SNMP management interfaces.
With the built-in Web-based management interface, the IGS-4215-16P4X offers an easy-to-use, platform-independent management and configuration facility.
For text-based command line management, it can be accessed via Telnet, SSH and the console port.
By supporting the standard SNMP protocol, the switch can be managed via any SNMP-based management software.
Moreover, the IGS-4215-16P4X offers secure remote management by supporting SSHv2, TLSv1.3 and SNMPv3 connections which encrypt the packet content at each session.
Flexible Long-distance Extension Solution
The emergence of 10G Ethernet marks a significant advancement in Ethernet technology. The IGS-4215-16P4X is a powerful networking device that offers four 10G SFP+ slots capable of supporting three different speeds. These slots can operate at 10GBASE-SR/LR or 100M/1G/2.5GBASE-SX/LX backwards, providing administrators with flexibility in choosing the most suitable SFP/SFP+ transceiver based on the required transmission distance and speed. With ample bandwidth and robust processing capacity, the IGS-4215-16P4X provides an efficient solution for administrators seeking to enhance their network infrastructure.
Intelligent SFP Diagnosis Mechanism
The IGS-4215-16P4X supports SFP-DDM (Digital Diagnostic Monitor) function that can easily monitor real-time parameters of the SFP for the network administrator, such as optical output power, optical input power, temperature, laser bias current, and transceiver supply voltage.

Remote Management Solution
PLANET's Universal Network Management System (UNI-NMS) and CloudViewerPro app provide robust support for IT staff in effectively managing and monitoring all network devices, including the IGS-4215-16P4X, from remote locations. Tailored for deployment in both enterprises and industries where the IGS-4215-16P4X is utilized remotely, these systems enable the identification of bugs or faulty conditions without the need for on-site visits. With UNI-NMS or the CloudViewerPro app, businesses of all types can now be swiftly and efficiently managed through a unified platform, streamlining operational oversight.

Applications
Industrial-grade PoE+ Switch for Building Automation and Security
Ideal for buildings with strict security requirements, the IGS-4215-16P4X, with its 16 802.3at PoE+ ports, is well-suited for creating a centrally managed power and network system for IP phone systems, IP surveillance, and wireless AP groups in industrial environments. For instance, up to 16 PoE IP cameras or wireless APs can be installed to meet surveillance needs or establish a wireless roaming network in industrial areas. By eliminating power socket limitations, the IGS-4215-16P4X simplifies the installation of IP cameras and wireless APs, enhancing efficiency and flexibility.

Perfect Integration Solution for IP PoE Camera and NVR System
The IGS-4215-16P4X features 16 10/100/1000BASE-T 802.3at PoE+ ports, providing ample power for up to 16 PoE IP cameras simultaneously. Additionally, its four 10GBASE-X SFP+ interfaces allow for seamless connection to a core fiber switch, enabling video streams to be sent to an NVR and monitoring center. With its high-performance switch architecture, the IGS-4215-16P4X ensures that recorded video files from all connected cameras are efficiently stored in the NVR system. Furthermore, the NVR system can be managed and monitored locally over the LAN or remotely via the Internet. The IGS-4215-16P4X delivers a reliable and cost-effective solution for secure surveillance systems.

Key Features
Physical Port
16 10/100/1000BASE-T Gigabit Ethernet RJ45 ports
PoE Functionality: 16 ports with IEEE 802.3at PoE+ injector function
4 10GBASE-SR/LR SFP+ slots, backward compatible with 100M/1G/2.5GBASE-X SFP
One USB Type C console interface for basic management and setup
Power over Ethernet
Powers up to 16 ports of IEEE 802.3at PoE+ devices
PoE budget
Dual power input: 360W
Single power input: 240W
Supports PoE power up to 36 watts for each PoE+ port
Auto detects powered devices (PDs)
Circuit protection prevents power interference between ports
Remote power feeding up to 100 meters in standard mode and 250m in extended mode
PoE management
Total PoE power budget control
Per port PoE function enable/disable
PoE port power feeding priority
Per PoE port power limitation
PD classification detection
Intelligent PoE features
Temperature threshold control
PoE extension
PD alive check
PoE schedule
Industrial Protocol
Modbus TCP for real-time monitoring in the SCADA system
Industrial Case and Installation
IP30 aluminum case
DIN-rail and wall-mount designs
IGS-4215-16P4X: 48~54V DC (redundant power with reverse polarity protection)
Supports 6KVDC Ethernet ESD protection
-40 to 75 °C operating temperature
Digital Input and Digital Output
2 digital input (DI)
2 digital output (DO)
Integrate sensors into auto alarm system
Transfer alarm to IP network via SNMP trap
Switching
Hardware-based 10/100Mbps (half/full duplex), 1000Mbps (full duplex), auto-negotiation and auto MDI/MDI-X
IEEE 802.3x flow control for full duplex operation and back pressure for half duplex operation
32K MAC address table size
12K jumbo frame
Automatic address learning and address aging
Layer 3 IP Routing Features
Supports maximum 32 static routes and route summarization
Routing interface provides per VLAN routing mode
Layer 2 Features
Supports VLAN
IEEE 802.1Q tagged VLAN
Provider bridging (VLAN Q-in-Q, IEEE 802.1ad) support
Protocol VLAN
Voice VLAN
Private VLAN (Protected port)
Management VLAN
GVRP
Supports Spanning Tree Protocol
STP (Spanning Tree Protocol)
RSTP (Rapid Spanning Tree Protocol)
MSTP (Multiple Spanning Tree Protocol)
STP BPDU Guard, BPDU Filtering and BPDU Forwarding
Supports Link Aggregation
IEEE 802.3ad Link Aggregation Control Protocol (LACP)
Cisco ether-channel (static trunk)
Maximum 8 trunk groups, up to 8 ports per trunk group
Supports port mirror (many-to-1)
Loop protection to avoid broadcast loops
Supports ERPS (Ethernet Ring Protection Switching)
Link Layer Discovery Protocol (LLDP)
Quality of Service
Ingress/Egress Rate Limit per port bandwidth control
Traffic classification
IEEE 802.1p CoS
TOS/DSCP/IP precedence of IPv4/IPv6 packets
Strict priority and Weighted Round Robin (WRR) CoS policies
Multicast
Supports IPv4 IGMP snooping v2, v3
Supports IPv6 MLD snooping v1, v2
IGMP querier mode support
IGMP snooping port filtering
MLD snooping port filtering
Security
Storm Control support
Broadcast / Multicast / Unknown Unicast
Authentication
Built-in RADIUS client to cooperate with the RADIUS servers
DHCP Option 82
RADIUS/TACACS+ authentication
Access Control List
IPv4/IPv6 IP-based ACL
IPv4/IPv6 IP-based ACE
MAC-based ACL
MAC-based ACE
MAC Security
Static MAC
MAC filtering
Port security for source MAC address entries filtering
DHCP snooping to filter distrusted DHCP messages
Dynamic ARP inspection discards ARP packets with invalid MAC address to IP address binding
IP source guard prevents IP spoofing attacks
DoS attack prevention
Management
IPv4 and IPv6 dual stack management
Switch Management Interface
Web switch management
Console/Telnet Command Line Interface
SNMP v1 and v2c switch management
SSHv2, TLSv1.3 and SNMPv3 secure access
SNMP Management
SNMP trap for interface Link Up and Link Down notification
Four RMON groups (history, statistics, alarms and events)
User privilege levels control
Built-in Trivial File Transfer Protocol (TFTP) client
Static and DHCP for IP address assignment
System Maintenance
Firmware upload/download via HTTP/TFTP
Configuration upload/download through HTTP/TFTP
Dual images
Hardware reset button for system reboot or reset to factory default
SNTP Network Time Protocol
Network Diagnostic
Cable diagnostics
ICMPv6/ICMPv4 Remote Ping
SFP-DDM (Digital Diagnostic Monitor)
Link Layer Discovery Protocol (LLDP) Protocol and LLDP-MED
Event message logging to remote syslog server
PLANET Smart Discovery Utility for deployment management
PLANET NMS system, NMSViewerPro, and CloudViewer/CloudViewerPro for deployment management
| Hardware Specifications | |||
| Copper Ports | 16 10/100/1000BASE-T RJ45 auto-MDI/MDI-X ports (Ports 1 to 16) | PoE Injector Port | 16 ports with 802.3at PoE+ injector function (Ports 1 to 16) |
| SFP+ Ports | 4 10GBASE-SR/LR SFP+ interfaces (Port XG1 to Port XG4) Backward compatible with 100M/1G/2.5GBASE-SX/LX/BX SFP transceivers |
Console | 1 x USB Type C to RS232 serial port (115200, 8, N, 1) |
| Reset Button | < 5 sec: System reboot > 5 sec: Factory default |
Connector | Removable 6-pin terminal block Pin 1/2 for Power 1; Pin 3/4 for fault alarm; Pin 5/6 for Power 2 Removable 6-pin terminal block for DI/DO interface Pin 1/2 for DI 1 & 2, Pin 3/4 for DO 1 & 2, Pin 5/6 for GND |
| Alarm | One relay output for power failure. Alarm relay current carry ability: 1A @ 24V AC |
Digital Input (DI) | 2 digital input (DI): Level 0: -24V~2.1V (±0.1V) Level 1: 2.1V~24V (±0.1V) Input load to 24V DC, 10mA max. |
| Digital Output (DO) | 2 digital output (DO): Open collector to 24V DC, 100mA max. |
Power Requirements | 48~54V DC, 9A (max.) |
| Power Consumption / Dissipation |
DC (system on) Max. 9.1 watts / 31.06BTU DC (Full loading) Max. 402 watts / 1,372.1BTU |
Dimensions (W x D x H) | 86 x 135 x 152 mm |
| Weight | 1,754g | Enclosure | IP30 aluminum case |
| Installation | DIN-rail kit and wall-mount ear | ESD Protection | Contact Discharge 6KV DC Air Discharge 8KV DC |
| LED |
System: Power 1 (Green) Power 2 (Green) Alarm (Red) Ring (Green) R.O. (Green) I/O (Red) Per 10/100/1000T RJ45 PoE+ Port: Up: 1000 LNK/ACT (Green) 10/100 LNK/ACT (Amber) Down: PoE-in-Use (Amber) Per 10G SFP Interface: 1G/2.5G LNK/ACT (Green) 100/10G LNK/ACT (Amber) |
||
| Switching Specification | |||
| Switch Architecture | Store-and-Forward | Switch Fabric | 112Gbps/non-blocking |
| Switch Throughput @64 bytes | 83.33Mpps @64 bytes | MAC Address Table | 32K entries |
| Shared Data Buffer | 12Mbits | Flow Control | IEEE 802.3x pause frame for full duplex Back pressure for half duplex |
| Jumbo Frame | 12 Kbytes | ||
| Power over Ethernet | |||
| PoE Standard | IEEE 802.3at Power over Ethernet Plus/PSE | PoE Power Supply Type | End-span |
| Power Pin Assignment | 802.3at PoE: End-span: 1/2(+), 3/6(-) | PoE Power Output | IEEE 802.3af Standard Per port 48V~51V DC, max. 15.4 watts IEEE 802.3at Standard Per port 51V~54V DC, max. 36 watts |
| PoE Power Budget | Single power input: 240W maximum (depending on power input) Dual power input: 360W maximum (depending on power input) ※Dual power input must be the same as DC voltage, like dual 54V. |
Max. Number of Class 2 PDs (~6.5 watts) | 16 |
| Max. Number of Class 3 PDs (~13 watts) | 16 | Max. Number of Class 4 PDs (~25.5 watts) | 12 |
| PoE Management Functions | |||
| PoE Management | PD Alive Check Scheduled Power Recycling PoE Schedule PoE Usage Monitoring PoE Extension |
Enhanced PoE Mode | Standard/Legacy/Force |
| Active PoE Device Live Detection | Yes | PoE Power Recycling | Yes, daily or predefined schedule |
| PoE Schedule | 4 schedule profiles | PoE Extend Mode | Yes, max. up to 250 meters |
| Layer 2 Functions | |||
| Port Mirroring | TX/RX/Both Many-to-1 monitor Up to 4 sessions |
VLAN | 802.1Q tagged VLAN 802.1ad Q-in-Q tunneling (VLAN stacking) Voice VLAN Protocol VLAN Private VLAN (Protected port) GVRP Management VLAN Up to 256 VLAN groups, out of 4094 VLAN IDs |
| Link Aggregation | IEEE 802.3ad LACP and static trunk Supports 8 groups with 8 ports per trunk |
Spanning Tree Protocol | IEEE 802.1D Spanning Tree Protocol (STP) IEEE 802.1w Rapid Spanning Tree Protocol (RSTP) IEEE 802.1s Multiple Spanning Tree Protocol (MSTP) STP BPDU Guard, BPDU Filtering and BPDU Forwarding |
| IGMP Snooping | IPv4 IGMP snooping v2, v3 IGMP Querier Up to 256 multicast groups |
MLD Snooping | IPv6 MLD snooping v2, v3, up to 256 multicast groups |
| Access Control List | IPv4/IPv6 IP-based ACL/MAC-based ACL IPv4/IPv6 IP-based ACE/MAC-based ACE |
QoS | 8 mapping IDs to 8 level priority queues Port number 802.1p priority DSCP/IP precedence of IPv4/IPv6 packets Traffic classification based, strict priority and WRR Ingress/Egress Rate Limit per port bandwidth control |
| Ring | Supports ERPS, and complies with ITU-T G.8032 Recovery time < 450ms |
||
| Layer 3 Functions | |||
| IP Interfaces | Max. 64 VLAN interfaces | Routing Table | Max. 32 routing entries |
| Routing Protocols | IPv4/IPv6 hardware static routing | ||
| Security Functions | |||
| Access Control List | IPv4/IPv6 IP-based ACL/MAC-based ACL IPv4/IPv6 IP-based ACE/MAC-based ACE Max. 256 ACL entries |
Port Security | Built-in RADIUS client to co-operate with RADIUS server RADIUS/TACACS+ user access authentication |
| MAC Security | IP-MAC port binding MAC filtering Static MAC address, max. 256 static MAC entries |
Enhanced Security | DHCP Snooping and DHCP Option82 STP BPDU guard, BPDU filtering and BPDU forwarding DoS attack prevention ARP inspection IP source guard |
| Management Functions | |||
| Basic Management Interfaces | USB to RS232 Console Web browser Telnet SNMP v1, v2c |
Secure Management Interfaces | SSHv2, TLSv1.3, SNMPv3 |
| System Management | Firmware upgrade by HTTP/TFTP protocol through Ethernet network Configuration upload/download through HTTP/TFTP LLDP protocol SNTP PLANET Smart Discovery Utility PLANET NMS System/CloudViewer/CloudViewerPro |
Event Management | Remote/Local Syslog System log |
| SNMP MIBs | RFC 1213 MIB-II RFC 1215 Generic Traps RFC 1493 Bridge MIB RFC 2674 Bridge MIB Extensions RFC 2737 Entity MIB (Version 2) RFC 2819 RMON (1, 2, 3, 9) RFC 2863 Interface Group MIB RFC 3635 Ethernet-like MIB RFC 3621 Power Ethernet MIB |
||
| Standards Conformance | |||
| Regulatory Compliance | FCC Part 15 Class A, CE | Stability Testing | IEC 60068-2-32 (free fall) IEC 60068-2-27 (shock) IEC 60068-2-6 (vibration) |
| Standards Compliance | IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000BASE-T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x Flow Control and Back Pressure IEEE 802.3ad Port Trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN Tagging IEEE 802.1ab LLDP IEEE 802.3af Power over Ethernet IEEE 802.3at Power over Ethernet Plus IEEE 802.3bt Power over Ethernet Plus Plus IEEE 802.3az for Energy-Efficient Ethernet RFC 768 UDP RFC 783 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2 ITU-T G.8032 ERPS Ring |
||
| Environment | |||
| Operating Temperature | -40 ~ 75 degrees C | Storage Temperature | -40 ~ 85 degrees C |
| Humidity | 5 ~ 95% (non-condensing) | ||
| Description | Downloads |
|---|---|
| Datasheet | Download |
Compare picture quality, touchscreen performance, software and connectivity with guidance from a commercial display specialist.
Access project pricing, volume discounts, product sourcing support and faster commercial quotations for your client projects.
Access education pricing, purchase-order support, installation services and account management for schools, academies, colleges, universities, NHS organisations, councils and government bodies.
Demonstrates consistently strong fulfilment, service, and post-sale experience across Google signals.
Great products and service! The guys always go above and beyond to make sure they supply you with the product that best fits your needs. I’ve been using Screen Moove for a number of years now and woul...
See moreScreen Moove went above and beyond for my requirements. Ordering system was super easy it just take 2 minutes to complete my order and I have received my tracking details right away after few minutes...
See moreMoe Khan, one of the team at Screen Move has been a fantastic help as we have navigated the process of choosing and buying screens and stands for our church. Helpful at every step of the way, patient...
See moreWe originally planned to purchase a cheap TV for our showrooms. After speaking with screen moove, we ended up investing in floorstanding displays across multiple retail sites and showrooms. The bright...
See moreI placed my order late at night but realized I had entered the wrong address. I immediately sent an email asking for it to be changed, not really expecting a reply until the next day. To my surprise,...
See moreI’ve been looking ultra high brightness display despite I checked everywhere I didn’t trust. They got my trust and I ordered. It arrived safely next day we have installed screen is awesome and high qu...
See moreThis is second time I used Screen Moove, I have bought double sided 55 inch display. The first order was a bit delayed I don't blame it might be happen, but customer service over the phone was excell...
See moreScreenmoove, perfect customer satisfaction from start to finish! Their customer service is incredibly helpful and fast. It’s amazing to be able to reach out and get quick solutions for any issue. We a...
See moreWe found that we needed a video call to work out the set up. The tech team at screenmoove were very very good. I would suggest that the instructions that come with the screen offer two key info. 1. Set...
See moreGreat experience with Jonathan Gray, previously I was looking for other companies and randomly ordering our needs from elsewhere. after I met with him, since 2024 we are keep purchasing from screen m...
See moreSpeak directly with Screen Moove about your display, digital signage, meeting-room or AV project.
Speak directly with a dedicated Screen Moove expert and get the right solution first time.
Simply complete our contact form, and we will promptly respond to your inquiries.
If you have any questions or enquiry, please fill out the form below with all of your details and we'll get back to you shortly.
Contact our team of experts today!