Book a Free Product Demonstration
Compare picture quality, touchscreen performance, software and connectivity with guidance from a commercial display specialist.
10Gbps Fiber Ports and Multiple Dual Speed Ports Deliver High-speed Networking
PLANET IGS-6325-16T4X is a powerhouse in industrial networking designed to optimize performance. This Layer 3 managed switch boasts a high-density combination of copper and fiber optic interfaces, setting the stage for superior connectivity. With 16 10/100/1000BASE-T RJ45 ports and 4 10GBASE-SR/LR SFP+ ports, it's equipped to handle diverse demands. Housed in a rugged IP30 metal case with DIN-rail compatibility, it thrives in extreme environments spanning from -40 to 75 degrees Celsius.
Featuring a 10Gbps uplink, the IGS-6325-16T4X seamlessly manages substantial data loads within a secure topology. Whether connecting to an industrial backbone or high-capacity servers, its prowess is unmatched. Operating flawlessly across an extensive temperature range, it guarantees a non-blocking switch fabric, delivering astonishing wire-speed throughput of up to 112Gbps. This transformative capability simplifies the process of industrial LAN upgrades, efficiently catering to escalating bandwidth requirements.
From demanding conditions to intensive data streams, the IGS-6325-16T4X emerges as the ultimate choice for enhancing industrial network performance.


Flexible and Extendable 10Gb Ethernet Solution
10G Ethernet is a big leap in the evolution of Ethernet. Each of the 10G SFP+ slots in the IGS-6325-16T4X supports triple speed and 10GBASE-SR/LR, 2500BASE-X or 1000BASE-SX/LX, providing broad bandwidth and powerful processing capacity. With its 2-port, 10G Ethernet link capability, the administrator now can flexibly choose the suitable SFP/SFP+ transceiver according to the transmission distance or the transmission speed required to extend the network efficiently.
Intelligent SFP Diagnosis Mechanism
The IGS-6325-16T4X supports SFP-DDM (digital diagnostic monitor) function that greatly helps network administrator to easily monitor real-time parameters of the SFP transceivers, such as optical output power, optical input power, temperature, laser bias current, and transceiver supply voltage.

Redundant Ring, Fast Recovery for Critical Network Applications
The IGS-6325-16T4X supports redundant ring technology and features strong, rapid self-recovery capability to prevent interruptions and external intrusions. It incorporates advanced ITU-T G.8032 ERPS (Ethernet Ring Protection Switching) technology, Spanning Tree Protocol (802.1s MSTP), and redundant power input system into customer’s industrial automation network to enhance system reliability and uptime in harsh factory environments. In a simple Ring network, the recovery time of data link can be as fast as 10ms.

Environmentally Hardened Design
With IP30 aluminum case, the Industrial Managed Switch provides a high level of immunity against electromagnetic interference and heavy electrical surges which are usually found on plant floors or in curb-side traffic control cabinets. It also possesses an integrated power supply source with a wide range of voltages for worldwide high availability applications requiring dual or backup power inputs. Being able to operate under the temperature range from -40 to 75 degrees C, the Industrial Managed Switch can be placed in almost any difficult environment.
Network with Cybersecurity Helps Minimize Security Risks
The IGS-6325-16T4X comes with enhanced cybersecurity to fend off cyberthreats and cyberattacks. It supports SSHv2 and TLS v1.2 protocols to provide strong protection against advanced threats. Served as a key point to transmit data over multiple long distance fiber optical connections to customer's critical equipment in a business network, the cybersecurity feature of the IGS-6325-16T4X protects the switch management and enhances the security of the mission-critical network without any extra deployment cost and effort.

Modbus TCP Provides Flexible Network Connectivity for Factory Automation
With the supported Modbus TCP/IP protocol, the IGS-6325-16T4X can easily integrate with SCADA systems, HMI systems and other data acquisition systems in factory floors. It enables administrators to remotely monitor the industrial Ethernet switch’s operating information, port information, communication status, and DI and DO status, thus easily achieving enhanced monitoring and maintenance of the entire factory.
1588 Time Protocol for Industrial Computing Networks
The IGS-6325-16T4X is ideal for telecom and carrier Ethernet applications, supporting MEF service delivery and timing over packet solutions for IEEE 1588 and synchronous Ethernet.

Redundant Power to Ensure Continuous Operation
The IGS-6325-16T4X possesses dual DC 9~48V and AC 24V power supply utilized as redundant power supply to ensure its continuous operation. Its redundant power system is specifically designed to handle the demands of high-tech facilities requiring the highest power integrity.
Effective Alarm Alert for Better Protection
The IGS-6325-16T4X supports a Fault Alarm feature which can alert the users when there is something wrong with the switches. With this ideal feature, the users would not have to waste time to find where the problem is. It will help to save time and human resource.

Digital Input and Digital Output for External Alarm
The IGS-6325-16T4X supports Digital Input and Digital Output on its front panel. This external alarm enables users to use Digital Input to detect and log external device status (such as door intrusion detector), and send event alarm to the administrators. The Digital Output could be used to alarm the administrators if the IGS-6325-16T4X port shows link down, link up or power failure.

Solution for IPv6 Networking
By supporting IPv6/IPv4 dual stack and plenty of management functions with easy and friendly-user interfaces, the Industrial Managed Switch is the best choice for IP surveillance, VoIP and wireless service providers to deploy the IPv6 network. It also helps the SMBs to step in the IPv6 era with the lowest investment but not necessary to replace the network facilities while the ISPs construct the IPv6 FTTx edge network.

IPv4 and IPv6 VLAN Routing for Secure and Flexible Management
To help customers stay on top of their businesses, the Industrial Managed Switch not only provides ultra high transmission performance and excellent Layer 2 technologies, but also offers IPv4/IPv6 VLAN routing feature which allows to cross over different VLANs and different IP addresses for the purpose of having a highly-secure, flexible management and simpler networking application.
IPv6/IPv4 Dual Stack
Supporting both IPv6 and IPv4 protocols, the IGS-6325-16T4X helps data centers, campuses, telecoms, and more to experience the IPv6 era with the lowest investment as its network facilities need not be replaced or overhauled if the IPv6 FTTx edge network is set up.
Layer 3 Routing Support
The IGS-6325-16T4X enables the administrator to conveniently boost network efficiency by configuring Layer 3 IPv4/IPv6 VLAN static routing manually, and the IPv4 OSPFv2 (Open Shortest Path First) settings automatically. The OSPF is an interior dynamic routing protocol for autonomous system based on link state. The protocol creates a database for link state by exchanging link states among Layer 3 switches, and then uses the Shortest Path First algorithm to generate a route table based on that database.
Robust Layer 2 Features
The IGS-6325-16T4X can be programmed for advanced Layer 2 switch management functions such as dynamic port link aggregation, 802.1Q tagged VLAN, Q-in-Q VLAN, private VLAN, Multiple Spanning Tree Protocol (MSTP), Layer 2 to Layer 4 QoS, bandwidth control, IGMP snooping and MLD snooping. Via the aggregation of supporting ports, the IGS-6325-16T4X allows the operation of a high-speed trunk group that comes with multiple ports and supports fail-over as well.

User-friendly Management Interfaces
For efficient management, the IGS-6325-16T4X is equipped with console, Web and SNMP management interfaces.
With the built-in Web-based management interface, the IGS-6325-16T4X offers an easy-to-use, platform-independent management and configuration facility.
For text-based management, it can be accessed via Telnet and the console port.
For standard-based monitor and management software, it offers SNMPv3 connection which encrypts the packet content at each session for secure remote management.
Powerful Network Security
The IGS-6325-16T4X offers comprehensive Layer 2 to Layer 4 Access Control List (ACL) for enforcing security to the edge. It can be used to restrict network access by denying packets based on source and destination IP address, TCP/UDP ports or defined typical network applications. Its protection mechanism also comprises 802.1X Port-based and MAC-based user and device authentication. With the private VLAN function, communication between edge ports can be prevented to ensure user privacy.
Advanced IP Network Protection
The IGS-6325-16T4X also provides DHCP Snooping, IP Source Guard and Dynamic ARP Inspection functions to prevent IP snooping from attack and discard ARP packets with invalid MAC address. The network administrators can now construct highly-secure corporate networks with considerably less time and effort than before.
Excellent Traffic Control
The IGS-6325-16T4X is loaded with powerful traffic management and QoS features to enhance connection services by telecoms and ISPs. The QoS features include wire-speed Layer 4 traffic classifiers and bandwidth limit that are particularly useful for multi-tenant units, multi-business units, Telco and network service providers’ applications. It also empowers the industrial environment to take full advantage of the limited network resources and guarantees the best performance in VoIP and video conferencing transmission.
Modbus TCP Provides Flexible Network Connectivity for Factory Automation
With the supported Modbus TCP/IP protocol, the Industrial Managed Switch can easily integrate with SCADA systems, HMI systems and other data acquisition systems in factory floors. It enables administrators to remotely monitor the industrial Ethernet switch’s operating information, port information and communication status, thus easily achieving enhanced monitoring and maintenance of the entire factory.
Remote Management Solution
PLANET's Universal Network Management System (UNI-NMS) and CloudViewerPro app support IT staff by remotely managing all network devices and monitoring PDs' operational statuses. Thus, they're designed for both the enterprises and industries where deployments of PDs can be as remote as possible, without having to go to the actual location once a bug or faulty condition is found. With the UNI-NMS or CloudViewerPro app, all kinds of businesses can now be speedily and efficiently managed from one platform.

Applications
High Availability Mesh Networking Solution for Big Data System
To improve the technology of Optical Fiber Ethernet with highly-flexible, highly-extendable and easy-to-install features, the IGS-6325-16T4X offers up to 52Gbps data exchange speed via Optical Fiber interface and the transmission distance can be extended to 120km.
The IGS-6325-16T4X features strong, rapid, self-recovery capability to prevent interruptions and external intrusions. It incorporates ITU-T G.8032 ERPS (Ethernet Ring Protection Switching) into customer’s automation network to enhance system reliability and uptime. The IGS-6325-16T4X is the ideal solution for data centers, service providers and telecoms to build redundant connection and establish high bandwidth for Big Data server farm.

Layer 3 VLAN Routing
With the built-in, robust Layer 3 routing protocols, the IGS-6325-16T4X ensures reliable routing between VLANs and network segments. The routing protocols can be applied by VLAN interface with up to 4K dynamic routing entries. The IGS-6325-16T4X, certainly an ideal solution for industries, offers greater security, control and bandwidth conservation, and high-speed uplink.
Key Features
Physical Port
16 10/100/1000BASE-T Gigabit Ethernet RJ45 ports
4 10GBASE-SR/LR SFP+ slots, compatible with 1G/2.5GBASE-X SFP
One RJ45-to-RS232 console interface for basic management and setup
Industrial Protocol
Modbus TCP for real-time monitoring in the SCADA system
IEEE 1588v2 PTP (Precision Time Protocol) transparent clock mode
Industrial Hardened Design
Dual power input, redundant power with reverse polarity protection
DC 9 to 48V input or AC 24V input
Active-active redundant power failure protection
Backup of catastrophic power failure on one supply
Fault tolerance and resilience
DIN-rail and wall-mountable designs
IP30 aluminum case
Supports 6KV DC Ethernet ESD protection
-40 to 75 degrees C operating temperature
Digital Input and Digital Output
2 Digital Input (DI)
2 Digital Output (DO)
Integrates sensors into auto alarm system
Transfers alarm to IP network via email and SNMP trap
Layer 3 IP Routing Features
IP dynamic routing protocol supports RIP, OSPFv2 and OSPFv3
Supports maximum 128 static routes and route summarization
IPv4 dynamic routing protocol supports OSPFv2
IPv4/IPv6 hardware static routing
Routing interface provides per VLAN routing mode
Layer 2 Features
Prevents packet loss with back pressure (half-duplex) and IEEE 802.3x pause frame flow control (full-duplex)
High performance of Store-and-Forward architecture, and runt/CRC filtering eliminates erroneous packets to optimize the network bandwidth
Storm control support
Broadcast/Multicast/Unknown unicast
Supports VLAN
IEEE 802.1Q tagged VLAN
Up to 4K VLANs groups, out of 4095 VLAN IDs
Supports provider bridging (VLAN Q-in-Q IEEE 802.1ad)
Private VLAN Edge (PVE)
Protocol-based VLAN
MAC-based VLAN
Voice VLAN
GVRP (GARP VLAN Registration Protocol)
Supports Spanning Tree Protocol
IEEE 802.1D Spanning Tree Protocol (STP)
IEEE 802.1w Rapid Spanning Tree Protocol (RSTP)
IEEE 802.1s Multiple Spanning Tree Protocol (MSTP), spanning tree by VLAN
BPDU Guard
Supports Link Aggregation
802.3ad Link Aggregation Control Protocol (LACP)
Cisco ether-channel (static trunk)
Maximum 10 trunk groups, with 16 ports for each trunk
Up to 80Gbps bandwidth (full duplex mode)
Provides port mirror (many-to-1)
Port mirroring to monitor the incoming or outgoing traffic on a particular port
Loop protection to avoid broadcast loops
Link Layer Discovery Protocol (LLDP)
Compatible with Cisco uni-directional link detection(UDLD) that monitors a link between two switches and blocks the ports on both ends of the link if the link fails at any point between the two devices
Supports G.8032 ERPS (Ethernet Ring Protection Switching)
IEEE 1588 and Synchronous Ethernet network timing
Quality of Service
Ingress shaper and egress rate limit per port bandwidth control
8 priority queues on all switch ports
Traffic classification
IEEE 802.1p CoS
ToS/DSCP/IP Precedence of IPv4/IPv6 packets
IP TCP/UDP port number
Typical network application
Strict priority and Weighted Round Robin (WRR) CoS policies
Traffic-policing on the switch port
DSCP remarking
Voice VLAN
Multicast
Supports IPv4 IGMP snooping v1, v2 and v3
Supports IPv6 MLD snooping v1 and v2
Querier mode support
IPv4 IGMP snooping port filtering
IPv6 MLD snooping port filtering
MVR (Multicast VLAN Registration)
Security
Authentication
IEEE 802.1x port-based/MAC-based network access authentication
IEEE 802.1x authentication with guest VLAN
Built-in RADIUS client to cooperate with the RADIUS servers
RADIUS/TACACS+ users access authentication
Guest VLAN assigns clients to a restricted VLAN with limited services
Access Control List
IP-based Access Control List (ACL)
MAC-based Access Control List (ACL)
Source MAC/IP address binding
DHCP Snooping to filter distrusted DHCP messages
Dynamic ARP Inspection discards ARP packets with invalid MAC address to IP address binding
IP Source Guard prevents IP spoofing attacks
IP address access management to prevent unauthorized intruder
Management
IPv4 and IPv6 dual stack management
Switch Management Interfaces
Console and Telnet Command Line Interface
HTTP web switch management
SNMP v1 and v2c switch management
SSHv2, TLSv1.2 and SNMP v3 secure access
SNMP Management
Four RMON groups (history, statistics, alarms, and events)
SNMP trap for interface Link Up and Link Down notification
IPv6 IP address/NTP/DNS management
Built-in Trivial File Transfer Protocol (TFTP) client
BOOTP and DHCP for IP address assignment
System Maintenance
Firmware upload/download via HTTP
Reset button for system reboot or reset to factory default
Dual images
DHCP Relay
DHCP Option 82
DHCP Server
User Privilege levels control
Network Time Protocol (NTP)
Network Diagnostic
SFP-DDM (Digital Diagnostic Monitor)
Cable diagnostic technology provides the mechanism to detect and report potential cabling issues
ICMPv6/ICMPv4 remote ping
SMTP/Syslog remote alarm
System Log
PLANET Smart Discovery Utility for deployment management
PLANET UNI-NMS (Universal Network Management) and CloudViewerPro app for deployment management
| Hardware Specifications | |||
| Copper Ports | 16 10/100/1000BASE-T RJ45 auto-MDI/MDI-X ports | SFP Ports | - |
| SFP+ Ports | 4 10GBASE-SR/LR SFP+ slot interfaces (Port-17 to Port-20) Compatible with 1000BASE-SX/LX/BX and 2500BASE-X SFP transceiver |
Console | 1 x RJ45-to-RS232 serial port (115200, 8, N, 1) |
| SDRAM | 512Mbytes | Flash Memory | 64Mbytes |
| Reset Button | < 5 sec: System reboot > 5 sec: Factory default |
Connector | Removable 6-pin terminal block for power input Pin 1/2 for Power 1, Pin 3/4 for fault alarm, Pin 5/6 for Power 2 Removable 6-pin terminal block for DI/DO interface Pin 1/2 for DI 1 & 2, Pin 3/4 for DO 1 & 2, Pin 5/6 for GND |
| Alarm | One relay output for power failure. Alarm relay current carry ability: 1A @ 24V DC | Digital Input (DI) | 2 digital input: Level 0: -24~2.1V (±0.1V) Level 1: 2.1~24V (±0.1V) Input load to 24V DC, 10mA max. |
| Digital Output (DO) | 2 digital output: Open collector to 24VDC, 100mA |
Installation | DIN-rail or wall mounting |
| Enclosure | IP30 aluminum case | Dimensions (W x D x H) | 96 x 107 x 152 mm |
| Weight | 1,503 g | Power Requirements | DC 9~48V, 3.3A max. AC 24V, 2A max. |
| Power Consumption |
DC input: Max. 14.4 watts/49.13 BTU (system on) Max. 24 watts/81.89 BTU (Full loading) AC 24V input: Max. 13.5 watts/46.06 BTU (system on) Max. 23 watts/78.48 BTU (Full loading) |
ESD Protection | 6KV DC |
| Surge Protection | 4KV DC | LED Indicators |
System: Power 1 (Green), Power 2 (Green) Fault Alarm (Red) Ring (Green), Ring Owner (Green) DIDO (Red) Per 10/100/1000T RJ45 Port: 1000Mbps LNK/ACT (Green) 10/100Mbps LNK/ACT (Amber) Per SFP+ Port: 1G/2.5G LNK/ACT (Green) 10Gbps LNK/ACT (Amber) |
| Switching Specifications | |||
| Switch Architecture | Store-and-Forward | Switch Fabric | 112Gbps/non-blocking |
| Throughput | 83.3Mpps@64Bytes | Address Table | 32K entries, automatic source address learning and aging |
| Shared Data Buffer | 32Mbits | Flow Control | IEEE 802.3x pause frame for full duplex Back pressure for half duplex |
| Jumbo Frame | 10K bytes | ||
| Layer 3 Functions | |||
| IP Interfaces | Max. 128 VLAN interfaces | Routing Table | Max. 128 routing entries Max. 4K H/W routing table entries |
| Routing Protocols | IPv4 RIPv1/v2 for dynamic routing IPv4 OSPFv2 for dynamic routing IPv4 hardware static routing IPv6 OSPFv3 for dynamic routing IPv6 hardware static routing |
||
| Layer 2 Functions | |||
| Port Configuration | Port disable/enable Auto-negotiation 10/100/1000Mbps full and half duplex mode selection Flow control disable/enable Port link capability control |
Port Status | Display each port's speed duplex mode, link status, flow control status, auto-negotiation status, trunk status |
| Port Mirroring | TX/RX/Both Many-to-1 monitor RMirror – Remote Switched Port Analyzer (Cisco RSPAN) Supports up to 5 sessions |
VLAN | IEEE 802.1Q tagged VLAN IEEE 802.1ad Q-in-Q tunneling Private VLAN Edge (PVE) MAC-based VLAN Protocol-based VLAN Voice VLAN MVR (Multicast VLAN registration) GVRP (GARP VLAN Registration Protocol) Up to 4K VLAN groups, out of 4096 VLAN IDs |
| Spanning Tree Protocol | IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol BPDU Guard |
Link Aggregation | IEEE 802.3ad LACP/static trunk 10 trunk groups with 16 ports per trunk group |
| IGMP Snooping | IPv4 IGMP (v1/v2/v3) snooping IPv4 IGMP querier mode support Supports 255 IGMP groups |
MLD Snooping | IPv6 MLD (v1/v2) snooping IPv6 MLD querier mode support Supports 255 MLD groups |
| Ring | Supports ERPS, and complies with ITU-T G.8032 Supports major ring and sub-ring Recovery time < 10ms @ 3 units Recovery time < 50ms @ 16 units |
Synchronization | IEEE 1588v2 PTP (Precision Time Protocol) Peer-to-peer transparent clock End-to-end transparent clock |
| QoS | Traffic classification based, strict priority and WRR 8-level priority for switching: Port number 802.1p priority 802.1Q VLAN tag DSCP/ToS field in IP packet |
Bandwidth Control | Per port bandwidth control Ingress: 100Kbps~1000Mbps Egress: 100Kbps~1000Mbps |
| Security Functions | |||
| Access Control List | IP-based ACL/MAC-based ACL ACL based on: MAC Address IP Address Ethertype Protocol Type VLAN ID DSCP 802.1p Priority Up to 512 entries |
Security | Port security IP source guard, up to 512 entries Dynamic ARP inspection, up to 1K entries Command line authority control based on user level Static MAC address, up to 64 entries |
| AAA | RADIUS client TACACS+ client |
Network Access Control | IEEE 802.1x port-based network access control MAC-based authentication Local/RADIUS authentication |
| Management | |||
| Basic Management Interfaces | Console; Telnet; Web browser; SNMP v1, v2c | Secure Management Interfaces | SSHv2, TLS v1.2, SNMPv3 |
| System Management | Firmware upgrade by HTTP protocol through Ethernet network Configuration upload/download through HTTP Remote Syslog System log LLDP protocol NTP PLANET Smart Discovery Utility PLANET CloudViewerPro app |
Event Management | Remote syslog System log SMTP |
| SNMP MIBs | RFC 1213 MIB-II RFC 1493 Bridge MIB RFC 1643 Ethernet MIB RFC 2863 Interface MIB RFC 2665 Ether-Like MIB RFC 2819 RMON MIB (Group 1, 2, 3 and 9) RFC 2737 Entity MIB RFC 2618 RADIUS Client MIB RFC 2863 IF-MIB RFC 2933 IGMP-STD-MIB RFC 3411 SNMP-Frameworks-MIB RFC 4292 IP Forward MIB RFC 4293 IP MIB RFC 4836 MAU-MIB IEEE 802.1X PAE LLDP MAU-MIB |
||
| Standards Conformance | |||
| Regulatory Compliance | FCC Part 15 Class A, CE | Stability Testing | IEC60068-2-32 (free fall) IEC60068-2-27 (shock) IEC60068-2-6 (vibration) |
| Standards Compliance | IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3z Gigabit SX/LX IEEE 802.3ab Gigabit 1000T IEEE 802.3ae 10Gb/s Ethernet IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1ad Q-in-Q VLAN stacking IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3ah OAM IEEE 802.1ag Connectivity Fault Management (CFM) IEEE 802.3az Energy Efficient Ethernet (EEE) IEEE 1588 PTPv2 RFC 768 UDP RFC 1350 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1058 RIP v1 RFC 2453 RIP v2 RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2 RFC 2328 OSPF v2 RFC 2740 OSPF v3 ITU-T G.8032 ERPS Ring ITU-T Y.1731 Performance Monitoring |
||
| Environment | |||
| Operating | Temperature: -40 ~ 75 degrees C Relative Humidity: 5 ~ 95% (non-condensing) |
Storage | Temperature: -40 ~ 85 degrees C Relative Humidity: 5 ~ 95% (non-condensing) |
| Description | Downloads |
|---|---|
| Datasheet | Download |
Compare picture quality, touchscreen performance, software and connectivity with guidance from a commercial display specialist.
Access project pricing, volume discounts, product sourcing support and faster commercial quotations for your client projects.
Access education pricing, purchase-order support, installation services and account management for schools, academies, colleges, universities, NHS organisations, councils and government bodies.
Demonstrates consistently strong fulfilment, service, and post-sale experience across Google signals.
Great products and service! The guys always go above and beyond to make sure they supply you with the product that best fits your needs. I’ve been using Screen Moove for a number of years now and woul...
See moreScreen Moove went above and beyond for my requirements. Ordering system was super easy it just take 2 minutes to complete my order and I have received my tracking details right away after few minutes...
See moreMoe Khan, one of the team at Screen Move has been a fantastic help as we have navigated the process of choosing and buying screens and stands for our church. Helpful at every step of the way, patient...
See moreWe originally planned to purchase a cheap TV for our showrooms. After speaking with screen moove, we ended up investing in floorstanding displays across multiple retail sites and showrooms. The bright...
See moreI placed my order late at night but realized I had entered the wrong address. I immediately sent an email asking for it to be changed, not really expecting a reply until the next day. To my surprise,...
See moreI’ve been looking ultra high brightness display despite I checked everywhere I didn’t trust. They got my trust and I ordered. It arrived safely next day we have installed screen is awesome and high qu...
See moreThis is second time I used Screen Moove, I have bought double sided 55 inch display. The first order was a bit delayed I don't blame it might be happen, but customer service over the phone was excell...
See moreScreenmoove, perfect customer satisfaction from start to finish! Their customer service is incredibly helpful and fast. It’s amazing to be able to reach out and get quick solutions for any issue. We a...
See moreWe found that we needed a video call to work out the set up. The tech team at screenmoove were very very good. I would suggest that the instructions that come with the screen offer two key info. 1. Set...
See moreGreat experience with Jonathan Gray, previously I was looking for other companies and randomly ordering our needs from elsewhere. after I met with him, since 2024 we are keep purchasing from screen m...
See moreSpeak directly with Screen Moove about your display, digital signage, meeting-room or AV project.
Speak directly with a dedicated Screen Moove expert and get the right solution first time.
Simply complete our contact form, and we will promptly respond to your inquiries.
If you have any questions or enquiry, please fill out the form below with all of your details and we'll get back to you shortly.
Contact our team of experts today!