Book a Free Product Demonstration
Compare picture quality, touchscreen performance, software and connectivity with guidance from a commercial display specialist.
Innovative Industrial TSN Ethernet Switch Guarantees Delivery of Time-Sensitive Data
PLANET TSN-5225-4T is a brand-new Industrial-grade Layer 2+ Time-Sensitive Networking (TSN) Managed Ethernet Switch which features 4 10/100/1000BASE-T RJ45 ports in a rugged IP30 metal case for stable operation in heavy environments, and addresses all levels of the industrial automation network, from the field bus to the factory backbone. And it guarantees end-to-end transmission of high-priority traffic with extremely low latency.
The TSN-5225-4T can be installed in any difficult environment as it can operate stably under the temperature range from -40 to 75 degrees C. It also allows either DIN-rail or wall mounting for efficient use of cabinet space.
Building a Sustainable Future for Innovation with ESG Principles
The TSN-5225-4T can help businesses achieve more efficient operations and production while reducing energy consumption and resource wastage, thereby enhancing both the economic and social benefits of the enterprise, aligning with the core values of ESG. For instance, the application of the TSN-5225-4T in industrial automation enables precise control of the manufacturing process, reducing energy consumption and waste generation. Similarly, their use in transportation can optimize logistics routes, mitigating issues such as carbon emissions and traffic congestion.
A Simplified Pathway to a TSN-compatible Infrastructure
PLANET TSN-5225-4T provides real-time, low-latency network communication for industrial automation, 5G NR networks, Industry 4.0, 4K/8K video streaming, and VR/AR gaming industry by using the Time-sensitive Networking (TSN) technology and IEEE 1588 Precision Time Protocol (PTPv2) for time synchronization on all ports.
The TSN-5225-4T supports TSN IEEE standards needed for a complete real-time communication solution. These include IEEE 802.1AS-REV profile for time synchronization, IEEE 802.1Qbv for Enhancements for Scheduled Traffic, IEEE 802.1Qbu Frame Preemption, IEEE 802.3br Interspersing Express Traffic (IET), IEEE 802.1Qci for per-stream filtering and policing (PSFP) and IEEE 802.1CB frame replication and elimination for reliability (FRER) for seamless redundancy.
The TSN-5225-4T eliminates the need for separating information technology (IT) and operational technology (OT) Ethernet networks, providing a more ubiquitous approach to synchronization and precision timing for today’s industrial automation systems.

1588 Time Protocol for Industrial Computing Networks
The TSN-5225-4T features IEEE 1588v2 PTP (Precision Time Protocol) with hardware-based time stamping for precise time synchronization of networks, and support for Boundary Clock, End to End and Peer to Peer Transparent Clock modes. It is ideal for telecom and carrier Ethernet applications, supporting MEF service delivery and timing over packet solutions for IEEE 1588 and synchronous Ethernet.

Redundant Ring, Fast Recovery for Critical Network Applications
The TSN-5225-4T supports redundant ring technology and features strong, rapid self-recovery capability to prevent interruptions and external intrusions. It incorporates advanced ITU-T G.8032 ERPS (Ethernet Ring Protection Switching) technology, Spanning Tree Protocol (802.1s MSTP), and redundant power input system into customer’s industrial automation network to enhance system reliability and uptime in harsh factory environments. In a simple ring network, the recovery time of data link can be as fast as 10ms.

Robust Layer 2 Features
The TSN-5225-4T can be programmed for advanced Layer 2 switch management functions such as dynamic port link aggregation, 802.1Q tagged VLAN, Q-in-Q VLAN, private VLAN, Multiple Spanning Tree Protocol (MSTP), Layer 2 to Layer 4 QoS, bandwidth control, IGMP snooping and MLD snooping. Via the aggregation of supporting ports, the TSN-5225-4T allows the operation of a high-speed trunk group that comes with multiple ports and supports fail-over as well.

Cybersecurity Network Solution to Minimize Security Risks
The cybersecurity features that virtually need no effort and cost to have include the protection of the switch management and the enhanced security of the mission-critical network. Both SSHv2 and TLSv1.2 protocols are utilized to provide strong protection against advanced threats. The network administrator can now construct highly-secure corporate networks with considerably less time and effort than before.

Modbus TCP Provides Flexible Network Connectivity for Factory Automation
With the supported Modbus TCP/IP protocol, the TSN-5225-4T can easily integrate with SCADA systems, HMI systems and other data acquisition systems in factory floors. It enables administrators to remotely monitor the industrial Ethernet switch’s operating information, port information, communication status, and DI and DO status, thus easily achieving enhanced monitoring and maintenance of the entire factory.
SMTP/SNMP Trap Event Alert
The TSN-5225-4T provides event alert function to help to diagnose the abnormal device owing to whether or not there is a break of the network connection, or the rebooting response.

Effective Alarm Alert for Better Protection
The TSN-5225-4T supports a Fault Alarm feature which can alert the users when there is something wrong with the switches. With this ideal feature, the users would not have to waste time to find where the problem is. It will help to save time and human resource.

Digital Input and Digital Output for External Alarm
The TSN-5225-4T supports Digital Input and Digital Output on its front panel. This external alarm enables users to use Digital Input to detect and log external device status (such as door intrusion detector), and send event alarm to the administrators. The Digital Output could be used to alarm the administrators if the TSN-5225-4T’s port shows link down, link up or power failure.

IPv6/IPv4 Dual Stack
Supporting both IPv6 and IPv4 protocols, the TSN-5225-4T helps data centers, campuses, telecoms, and more to experience the IPv6 era with the lowest investment as its network facilities need not be replaced or overhauled if the IPv6 FTTx edge network is set up.

Efficient Management
For efficient management, the TSN-5225-4T is equipped with console, Web and SNMP management interfaces.
With the built-in Web-based management interface, the TSN-5225-4T offers an easy-to-use, platform-independent management and configuration facility.
For text-based management, it can be accessed via Telnet and the console port.
For standard-based monitor and management software, it offers SNMPv3 connection which encrypts the packet content at each session for secure remote management.

Powerful Network Security
The TSN-5225-4T offers comprehensive Layer 2 to Layer 4 Access Control List (ACL) for enforcing security to the edge. It can be used to restrict network access by denying packets based on source and destination IP address, TCP/UDP ports or defined typical network applications. Its protection mechanism also comprises 802.1X Port-based and MAC-based user and device authentication. With the private VLAN function, communication between edge ports can be prevented to ensure user privacy.
Advanced IP Network Protection
The TSN-5225-4T also provides DHCP Snooping, IP Source Guard and Dynamic ARP Inspection functions to prevent IP snooping from attack and discard ARP packets with invalid MAC address. The network administrators can now construct highly-secure corporate networks with considerably less time and effort than before.
Excellent Traffic Control
The TSN-5225-4T is loaded with powerful traffic management and QoS features to enhance connection services by telecoms and ISPs. The QoS features include wire-speed Layer 4 traffic classifiers and bandwidth limit that are particularly useful for multi-tenant units, multi-business units, Telco and network service providers’ applications. It also empowers the industrial environment to take full advantage of the limited network resources and guarantees the best performance in VoIP and video conferencing transmission.
Layer 3 IPv4 and IPv6 Software VLAN Routing for Secure and Flexible Management
To help customers stay on top of their businesses, the TSN-5225-4T not only provides ultra high transmission performance and excellent Layer 2 technologies, but also IPv4/IPv6 software VLAN routing feature which allows to crossover different VLANs and different IP addresses for the purpose of having a highly-secure, flexible management and simpler networking application.
Remote Management Solution
PLANET's Universal Network Management System (UNI-NMS) and NMSViewerPro/CloudViewerPro app support IT staff by remotely managing all network devices and monitoring PDs' operational statuses. Thus, they're designed for both the enterprises and industries where deployments of PDs can be as remote as possible, without having to go to the actual location once a bug or faulty condition is found. With the UNI-NMS or NMSViewerPro/CloudViewerPro app, all kinds of businesses can now be speedily and efficiently managed from one platform.

Applications
TSN Technology for Efficient Real-time Monitoring of Factory Production Processes
PLANET TSN-5225-4T, based on its advanced Time-Sensitive Networking (TSN) technology and utilizing IEEE 1588 Precision Time Protocol (PTPv2) for time synchronization on all ports, provides an efficient solution. Leveraging real-time data monitoring and low-latency data transmission advantages, it can be used for real-time monitoring and management of factory production processes. This system harnesses the performance of TSN to enhance production efficiency, optimize resources, and enable quick response to faults, making it a highly promising solution.

Key Features
Physical Port
4 10/100/1000BASE-T Gigabit Ethernet RJ45 ports
One RJ45 console interface for basic management and setup
Industrial Case and Installation
Dual power input, redundant power with reverse polarity protection
DC 9 to 48V input or AC 24V input
Active-active redundant power failure protection
Backup of catastrophic power failure on one supply
Fault tolerance and resilience
IP30 metal case
DIN-rail and wall-mount designs
Supports 5000V DC Ethernet ESD protection
-40 to 75 degrees C operating temperature
Digital Input and Digital Output
2 digital input (DI)
2 digital output (DO)
Integrates sensors into auto alarm system
Transfers alarm to IP network via email and SNMP trap
Time Sensitive Networking
High Precision Time Synchronization
IEEE1588 (Time Stamping)
802.1AS-Rev gPTP default profile
Shapers
802.1Qbv Enhancements for Scheduled Traffic
802.1Qch (Cyclic Queuing and Forwarding)
TSN Stream Policing
802.1Qci (Per Stream Filtering and Policing)
Redundancy
802.1CB FRER for seamless redundancy
Also standard Linear and Ring protection
Delay Reduction
IEEE 802.1Qbu Frame Preemption,
IEEE 802.3br Interspersing Express Traffic (IET)
Layer 2 Features
Prevents packet loss with back pressure (half-duplex) and IEEE 802.3x pause frame flow control (full-duplex)
High performance of Store-and-Forward architecture, and runt/CRC filtering eliminates erroneous packets to optimize the network bandwidth
Storm Control support
Broadcast/Multicast/Unicast
Supports VLAN
IEEE 802.1Q tagged VLAN
Supports provider Bridging (VLAN Q-in-Q, IEEE 802.1ad)
Private VLAN Edge (PVE)
Port Isolation
MAC-based VLAN
Protocol-based VLAN
Voice VLAN
VLAN Translation
GVRP
Supports Spanning Tree Protocol
IEEE 802.1D Spanning Tree Protocol (STP)
IEEE 802.1w Rapid Spanning Tree Protocol (RSTP)
IEEE 802.1s Multiple Spanning Tree Protocol (MSTP), spanning tree by VLAN
BPDU Guard
Supports Link Aggregation
802.3ad Link Aggregation Control Protocol (LACP)
Cisco ether-channel (static trunk)
Maximum2 trunk groups with 4 ports per trunk group
Provides port mirror (many-to-1)
Port mirroring to monitor the incoming or outgoing traffic on a particular port
Loop protection to avoid broadcast loops
Supports ERPS (Ethernet Ring Protection Switching)
Compatible with Cisco Uni-directional link detection(UDLD) that monitors a link between two switches and blocks the ports on both ends of the link if the link fails at any point between the two devices
Link Layer Discovery Protocol (LLDP) and LLDP-MED
Layer 3 IP Routing Features
Supports maximum 32 static routes and route summarization
Quality of Service
Ingress Shaper and Egress Rate Limit per port bandwidth control
8 priority queues on all switch ports
Traffic classification
IEEE 802.1p CoS
IP TOS/DSCP/IP precedence
IP TCP/UDP port number
Typical network application
Strict priority and Weighted Round Robin (WRR) CoS policies
Supports QoS and In/Out bandwidth control on each port
raffic-policing on the switch port
DSCP remarking
Voice VLAN
Multicast
Supports IPv4 IGMP snooping v1, v2 and v3
Supports IPv6 MLD snooping v1 and v2
Querier mode support
IPv4 IGMP snooping port filtering
IPv6 MLD snooping port filtering
Multicast VLAN Registration (MVR) support
Security
Authentication
IEEE 802.1x Port-based/MAC-based network access authentication
Built-in RADIUS client to co-operate with the RADIUS servers
TACACS+ login users access authentication
RADIUS/TACACS+ users access authentication
Access Control List
IP-based Access Control List (ACL)
MAC-based Access Control List
Source MAC/IP address binding
DHCP Snooping to filter un-trusted DHCP messages
Dynamic ARP Inspection discards ARP packets with invalid MAC address to IP address binding
IP Source Guard prevents IP spoofing attacks
IP address access management to prevent unauthorized intruder
Management
IPv4 and IPv6 dual stack management
Switch Management Interfaces
Console/Telnet Command Line Interface
Web switch management
SNMP v1, v2c, and v3 switch management
SSHv2 and TLSv1.2 secure access
IPv6 IP Address/NTP/DNS management
Built-in Trivial File Transfer Protocol (TFTP) client
BOOTP and DHCP for IP address assignment
System Maintenance
Firmware upload/download via HTTP
Configuration upload/download through HTTP
Reset button for system reboot or reset to factory default
Dual Images
DHCP Relay
DHCP Option82
DHCP Server Mode support
User Privilege levels control
NTP (Network Time Protocol)
Network Diagnostic
ICMPv6/ICMPv4 Remote Ping
SMTP/Syslog remote alarm
Four RMON groups (history, statistics, alarms and events)
SNMP trap for interface Link up and Link down notification
System Log
PLANET Smart Discovery Utility for deployment management
PLANET NMS comes with NMSViewerPro and CloudViewerPro applications for deployment management
| Hardware Specifications | |||
| Copper Ports | 4 10/100/1000BASE-T RJ45 auto-MDI/MDI-X ports | Console | 1 x RJ45-to-RS232 serial port (115200, 8, N, 1) |
| Reset Button | < 5 sec: System reboot > 5 sec: Factory default |
Connector | Removable 6-pin terminal block for power input Pin 1/2 for Power 1, Pin 3/4 for fault alarm, Pin 5/6 for Power 2 Removable 6-pin terminal block for DI/DO interface Pin 1/2 for DI 1 & 2, Pin 3/4 for DO 1 & 2, Pin 5/6 for GND |
| Alarm | One relay output for power failure. Alarm relay current carry ability: 1A @ 24V DC | Digital Input (DI) | 2 digital input: Level 0: -24~2.1V (±0.1V) Level 1: 2.1~24V (±0.1V) Input load to 24V DC, 10mA max. |
| Digital Output (DO) | 2 digital output: Open collector to 24VDC, 100mA |
Enclosure | IP30 aluminum case |
| Installation | DIN-rail or wall mounting | SDRAM | 1024Mbytes |
| Flash Memory | 64Mbytes | Dimensions (W x D x H) | 60 x 135 x 135 mm |
| Weight | 962g | Power Requirements | DC 9~48V, 1.5A max. AC 24V, 1A max. |
| Power Consumption |
DC input: Max. 8.36 watts/28.53BTU (system on) Max. 9.89 watts/33.75BTU (Full loading) AC 24V input: Max. 6.2 watts/21.16BTU (system on) Max. 7.9 watts/26.96BTU (Full loading) |
ESD Protection | 5KV DC |
| Surge Protection | 6KV DC | LED Indicators |
System: Power 1 (Green), Power 2 (Green) Fault Alarm (Red) Ring (Green), Ring Owner (Green) DIDO (Red) Per 10/100/1000T RJ45 Port: 1000Mbps LNK/ACT (Green) 10/100Mbps LNK/ACT (Amber) |
| Switching Specifications | |||
| Switch Architecture | Store-and-Forward | Switch Fabric | 8Gbps/non-blocking |
| Throughput | 5.95Mpps@64Bytes | Address Table | 8K entries, automatic source address learning and aging |
| Shared Data Buffer | 32Mbits | Jumbo Frame | 10K bytes |
| Flow Control | IEEE 802.3x pause frame for full duplex Back pressure for half duplex |
||
| Layer 3 Functions | |||
| IP Interfaces | Max. 8 VLAN interfaces | Routing Table | Max. 32 routing entries |
| Routing Protocols | IPv4 software static routing IPv6 software static routing |
||
| Layer 2 Functions | |||
| Port Configuration | Port disable/enable Auto-negotiation 10/100/1000Mbps full and half duplex mode selection Flow control disable/enable Port link capability control |
Port Status | Display each port’s speed duplex mode, link status, flow control status, auto-negotiation status, trunk status |
| Port Mirroring | TX/RX/Both Many-to-1 monitor Mirror – Remote Switched Port Analyzer (Cisco RSPAN) Supports up to 5 sessions |
VLAN | IEEE 802.1Q tagged VLAN IEEE 802.1ad Q-in-Q tunneling Private VLAN Edge (PVE) MAC-based VLAN Protocol-based VLAN Voice VLAN IP Subnet-based VLAN MVR (Multicast VLAN registration) GVRP Up to 4K VLAN groups, out of 4096 VLAN IDs |
| Link Aggregation | IEEE 802.3ad LACP/static trunk Maximum 2 trunk groups with 4 ports per trunk group |
Spanning Tree Protocol | IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol BPDU Guard, BPDU filtering and BPDU transparent |
| IGMP Snooping | IPv4 IGMP (v1/v2/v3) snooping IPv4 IGMP querier mode support Supports 255 IGMP groups |
MLD Snooping | IPv6 MLD (v1/v2) snooping IPv6 MLD querier mode support Supports 255 MLD groups |
| Bandwidth Control | Per port bandwidth control Ingress: 100Kb~3276Mbps Egress: 100Kb~3281Mbps |
Ring | Supports ERPS, and complies with ITU-T G.8032 Recovery time < 10ms @ 3 nodes Recovery time < 50ms @ 16 nodes Supports Major ring and sub-ring |
| Synchronization | IEEE 1588v2 PTP (Precision Time Protocol) PTP Master PTP Slave Boundary clock Ordinary Clock Peer-to-peer transparent clock End-to-end transparent clock |
QoS | Ingress Shaper and Egress Rate Limit per port bandwidth control 8 priority queues on all switch ports Traffic classification: IEEE 802.1p CoS IP TOS / DSCP / IP Precedence IP TCP/UDP port number Typical network application Traffic-policing policies on the switch port DSCP remarking |
| Time-Sensitive Networking Protocols |
High Precision Time Synchronization: IEEE1588 (Time Stamping) 802.1AS-Rev gPTP default profile Shapers: 802.1Qbv (Time-aware Scheduling) 802.1Qch (Cyclic Queuing and Forwarding) TSN Stream Policing: 802.1Qci (Per Stream Filtering and Policing) Redundancy: 802.1CB (Frame Replication and Elimination for Redundancy for seamless redundancy) Also standard Linear and Ring protection Delay Reduction: IEEE 802.1Qbu Frame Preemption IEEE 802.3br Interspersing Express Traffic (IET) |
||
| Security Functions | |||
| Access Control List | IP-based ACL/MAC-based ACL ACL based on: MAC Address IP Address Ethertype Protocol Type VLAN ID DSCP 802.1p Priority Up to 512 entries |
Security | Port security IP source guard, up to 512 entries Dynamic ARP inspection, up to 1K entries Command line authority control based on user level Static MAC address, up to 64 entries |
| AAA | RADIUS client TACACS+ client |
Network Access Control | IEEE 802.1x port-based network access control MAC-based authentication Local/RADIUS authentication |
| Management | |||
| Basic Management Interfaces | Console; Telnet; Web browser; SNMP v1, v2c | Secure Management Interfaces | SSHv2, TLSv1.2, SNMPv3 |
| System Management | Firmware upgrade by HTTP protocol through Ethernet network Configuration upload/download through HTTP Remote Syslog System log LLDP protocol NTP PLANET Smart Discovery Utility PLANET NMS PLANET NMSViewerPro/CloudViewerPro |
Event Management | Remote syslog Local system log SMTP |
| SNMP MIBs | RFC 1213 MIB-II RFC 1493 Bridge MIB RFC 1643 Ethernet MIB RFC 2863 Interface MIB RFC 2665 Ether-Like MIB RFC 2819 RMON MIB (Group 1, 2, 3 and 9) RFC 2737 Entity MIB RFC 2618 RADIUS Client MIB RFC 2863 IF-MIB RFC 2933 IGMP-STD-MIB RFC 3411 SNMP-Frameworks-MIB RFC 4292 IP Forward MIB RFC 4293 IP MIB RFC 4836 MAU-MIB IEEE 802.1X PAE LLDP |
||
| Standards Conformance | |||
| Regulatory Compliance | FCC Part 15 Class A CE: EN55032 EN55035 |
Stability Testing | IEC60068-2-32 (free fall) IEC60068-2-27 (shock) IEC60068-2-6 (vibration) |
| Standards Compliance | IEEE 802.3 10BASE-T IEEE 802.3u 100BASE-TX/100BASE-FX IEEE 802.3ab Gigabit 1000T IEEE 802.3x flow control and back pressure IEEE 802.3ad port trunk with LACP IEEE 802.1D Spanning Tree Protocol IEEE 802.1w Rapid Spanning Tree Protocol IEEE 802.1s Multiple Spanning Tree Protocol IEEE 802.1p Class of Service IEEE 802.1Q VLAN tagging IEEE 802.1X Port Authentication Network Control IEEE 802.1ab LLDP IEEE 802.3ah OAM IEEE 1588 PTPv2 IEEE 802.1ag Connectivity Fault Management (CFM) IEEE 802.1AS - Timing and Synchronization for Time-sensitive Applications IEEE 802.1Qbu Frame Preemption IEEE 802.3br Interspersing Express Traffic (IET) IEEE 802.1Qci Per-Stream Filtering and Policing (PSFP) IEEE 802.1Qbv Enhancements for Scheduled Traffic IEEE 802.1CB Frame Replication and Elimination for Reliability (FRER) RFC 768 UDP RFC 783 TFTP RFC 791 IP RFC 792 ICMP RFC 2068 HTTP RFC 1112 IGMP v1 RFC 2236 IGMP v2 RFC 3376 IGMP v3 RFC 2710 MLD v1 RFC 3810 MLD v2 ITU-T G.8032 ERPS Ring |
||
| Environment | |||
| Operating | -40 ~ 75 degrees C | Storage | -40 ~ 85 degrees C |
| Humidity | 5 ~ 95% (non-condensing) | ||
| Description | Downloads |
|---|---|
| Datasheet | Download |
Compare picture quality, touchscreen performance, software and connectivity with guidance from a commercial display specialist.
Access project pricing, volume discounts, product sourcing support and faster commercial quotations for your client projects.
Access education pricing, purchase-order support, installation services and account management for schools, academies, colleges, universities, NHS organisations, councils and government bodies.
Demonstrates consistently strong fulfilment, service, and post-sale experience across Google signals.
Great products and service! The guys always go above and beyond to make sure they supply you with the product that best fits your needs. I’ve been using Screen Moove for a number of years now and woul...
See moreScreen Moove went above and beyond for my requirements. Ordering system was super easy it just take 2 minutes to complete my order and I have received my tracking details right away after few minutes...
See moreMoe Khan, one of the team at Screen Move has been a fantastic help as we have navigated the process of choosing and buying screens and stands for our church. Helpful at every step of the way, patient...
See moreWe originally planned to purchase a cheap TV for our showrooms. After speaking with screen moove, we ended up investing in floorstanding displays across multiple retail sites and showrooms. The bright...
See moreI placed my order late at night but realized I had entered the wrong address. I immediately sent an email asking for it to be changed, not really expecting a reply until the next day. To my surprise,...
See moreI’ve been looking ultra high brightness display despite I checked everywhere I didn’t trust. They got my trust and I ordered. It arrived safely next day we have installed screen is awesome and high qu...
See moreThis is second time I used Screen Moove, I have bought double sided 55 inch display. The first order was a bit delayed I don't blame it might be happen, but customer service over the phone was excell...
See moreScreenmoove, perfect customer satisfaction from start to finish! Their customer service is incredibly helpful and fast. It’s amazing to be able to reach out and get quick solutions for any issue. We a...
See moreWe found that we needed a video call to work out the set up. The tech team at screenmoove were very very good. I would suggest that the instructions that come with the screen offer two key info. 1. Set...
See moreGreat experience with Jonathan Gray, previously I was looking for other companies and randomly ordering our needs from elsewhere. after I met with him, since 2024 we are keep purchasing from screen m...
See moreSpeak directly with Screen Moove about your display, digital signage, meeting-room or AV project.
Speak directly with a dedicated Screen Moove expert and get the right solution first time.
Simply complete our contact form, and we will promptly respond to your inquiries.
If you have any questions or enquiry, please fill out the form below with all of your details and we'll get back to you shortly.
Contact our team of experts today!